Oreo Audio Problem / Crackling Sound

  • Ok so one more problem since Oreo. I'm a big headphone user, use them almost everyday. Since upgrading to Oreo I've been getting these audio cracks, or whatever you call it, where the sound flickers extremely much. It's so damn annoying because it ruins the whole experience of listening to music and just makes you wanna smash your phone on the ground. In my experience it's not internet connected as it can happen everywhere. Probably bad RAM management or the CPU gets overloaded. Same thing but a lot less intrusive used to happen with Nougat too but always when the battery was very low (Nougat was famous for making the phone lag a lot when under a certain battery percentage). But with Oreo it can happen whenever. Has anyone else had this problem?

  • Ok so one more problem since Oreo. I'm a big headphone user, use them almost everyday. Since upgrading to Oreo I've been getting these audio cracks, or whatever you call it, where the sound flickers extremely much. It's so damn annoying because it ruins the whole experience of listening to music and just makes you wanna smash your phone on the ground. In my experience it's not internet connected as it can happen everywhere. Probably bad RAM management or the CPU gets overloaded. Same thing but a lot less intrusive used to happen with Nougat too but always when the battery was very low (Nougat was famous for making the phone lag a lot when under a certain battery percentage). But with Oreo it can happen whenever. Has anyone else had this problem?

    I do not have this problem.

    At first I had problems with the sampling rate, the output was limited to 16bit 48kHz.

    Solved the problem after I formatted the SD card as a device memory.

    Then I moved Poweramp and Neutron Player to the SD card and the sound was Head Blowing again.

    It can also be due to Oreo's energy options which are a little tricky.

    Which app do you use for music playback?

    App reinstallation can also help.

  • I use YouTube Music, now and back on Nougat too. I guess I can try reinstalling it again but I formatted the phone after installing Oreo so the app is practically 4 days old too 😅 thanks for the answer tho 👍🏻

    Do you have the problem even if you use the stock music player?

    Play around with the power options, optimize in the background and optimize on the lock screen.

    The two have a tremendous impact on the performance of the app

  • illumi241

    Added the Label 1.3B02